Users online right now: 105 - Login  » search  » forum index  

how to save xorg and configuration (solved)

sosoul24
wrote 5 years ago


reply
i got 2 problems as i firstly use linux OS.

i use TOSHIBA R100 latop to run it. i change the resolution to 1024 by altering the Xorg.conf. But when i restart my laptop all the modified xorg file just restore to the original one which makes the resolution bback to 800 And also all the changes i made and save at the saveslax.dat file restore as the xorg file do.


i see some one say pres "tab"at the begining pic during the power on process to access into the line:changes=.... then i can save the direction of the saveslax.dat ,but i press from the very begining til i see the DEsktop no "changes=.." appear
 
jcsoh
wrote 5 years ago


reply
On how to save:
http://www.slax.org/forum.php?action=view&parentID=33046
 
sosoul24
wrote 5 years ago


reply
jcsoh wrote:
On how to save:
http://www.slax.org/forum.php?action=view&parentID=33046


thx i'm on it
 
sosoul24
wrote 5 years ago


reply
i used the same way as the reference you gave me to directly change the slax.cfg but i found several independent changes which includes the last changes i made b4 but it seems everytime i restart it will write in a new one following is what my slax.cfg file conten

LABEL xconf
MENU LABEL Slax Graphics mode (KDE)
KERNEL /boot/vmlinuz
APPEND initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw autoexec=xconf;telinit~4 changes=/mnt/hda6/slaxsave.dat
TEXT HELP
More about currently selected:

Run Slax the best way we can.
Try to autoconfigure graphics
card and use the maximum
allowed resolution
ENDTEXT


LABEL fresh
MENU LABEL Slax Always Fresh
KERNEL /boot/vmlinuz
APPEND initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw autoexec=xconf;telinit~4
TEXT HELP
More about currently selected:

Normally Slax saves all changes
to the /slax/changes/ directory
on the boot media (if writable)
and restores them next time.
Use this option to start fresh
system, no changes are neither
read nor written anywhere
ENDTEXT

LABEL cp2ram
MENU LABEL Slax Copy To RAM
KERNEL /boot/vmlinuz
APPEND initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw copy2ram autoexec=xconf;telinit~4
TEXT HELP
More about currently selected:

Run Slax the same like above,
but first copy all data to RAM
to get huge speed (needs >300MB)
ENDTEXT

LABEL startx
MENU LABEL Slax Graphics VESA mode
KERNEL /boot/vmlinuz
APPEND initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw autoexec=telinit~4 changes=/slax/
TEXT HELP
More about currently selected:

Run Slax with KDE, but skip
gfx-card config. Force 1024x768
using standard VESA driver
ENDTEXT

LABEL slax
MENU LABEL Slax Text mode
KERNEL /boot/vmlinuz
APPEND initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw changes=/slax/
TEXT HELP
More about currently selected:

Run Slax in textmode and start
command prompt only
ENDTEXT
LABEL pxe
MENU LABEL Slax as PXE server
KERNEL /boot/vmlinuz
APPEND initrd=/boot/initrd.gz ramdisk_size=6666 root=/dev/ram0 rw autoexec=/boot/pxelinux.cfg/start;/boot/pxelinux.cfg/web/start;xconf;telinit~4
TEXT HELP
More about currently selected:

Run Slax as usual, but also
initialize PXE server.
This will allow you to boot Slax
on other computers over network
ENDTEXT


MENU SEPARATOR

LABEL memtest86
MENU LABEL Run Memtest utility
KERNEL /boot/mt86p
TEXT HELP
More about currently selected:

Don't start Slax at all, but
rather run the MemTest utility
to diagnose your computer's RAM
for possible errors
ENDTEXT
 
sosoul24
wrote 5 years ago


reply
well i've tried many ways to solve that problem

1.modify slax.cfg file as above. which i'm not very sure which line should i alter. iboot slax from harddisk and i wanna save changes to the slax. And there are several options in slax.cfg like fresh,cp2ram,startx.xconf. btw my slax boot initial file autoexec=xconf;starts,kdm if i delete the "xconf" i can't get boot ,and turn blackscreen instead.(but the back light is on)


2.creat xorg-fix.lzm and cp it to /mnt/hda1/slax/modules and i notice everytime when i boot slax the info tells that i both mount "xorg-fix.lzm" and "xconf" whould it effect?


3.edit the /etc/X11/gui.conf skip_xconf=yes


anyway none of them works
 
markds
wrote 5 years ago


reply
Create your version of xorg.conf and put it in /usr/share/slax for example. Then make a module out of it:

mkdir -p /tmp/myxorg/usr/share/slax; cp xorg.conf /tmp/myxorg/usr/share/slax
dir2lzm /tmp/myxorg xorgfixed.lzm

where the xorg.conf is YOUR VERSION of the xorg.conf (the one you modified)

Put the module into your slax/modules directory.

Edit your slax.cfg file and change "autoexec=xconf;telinit~4" to

autoexec=cp~/usr/share/slax/xorg.conf~/etc/X11/xorg.conf;telinit~4

Reboot and try.


sosoul24 wrote:
well i've tried many ways to solve that problem

1.modify slax.cfg file as above. which i'm not very sure which line should i alter. iboot slax from harddisk and i wanna save changes to the slax. And there are several options in slax.cfg like fresh,cp2ram,startx.xconf. btw my slax boot initial file autoexec=xconf;starts,kdm if i delete the "xconf" i can't get boot ,and turn blackscreen instead.(but the back light is on)


2.creat xorg-fix.lzm and cp it to /mnt/hda1/slax/modules and i notice everytime when i boot slax the info tells that i both mount "xorg-fix.lzm" and "xconf" whould it effect?


3.edit the /etc/X11/gui.conf skip_xconf=yes


anyway none of them works
 
bb as guest
wrote 5 years ago


reply
Sosoul24 --- you must avoid running xconf [which is part of the autoexec command in that first slax menu choice]; that is what is messing up your saved xorg.conf. It is run long after your saved version is restored, upon which it overwrites it with whatever fanciful rez it thinks your hardware will do.
 
sosoul24
wrote 5 years ago


reply
bb as guest wrote:
Sosoul24 --- you must avoid running xconf [which is part of the autoexec command in that first slax menu choice]; that is what is messing up your saved xorg.conf. It is run long after your saved version is restored, upon which it overwrites it with whatever fanciful rez it thinks your hardware will do.

i try but if i delete the "xconf" from the begining menu autoexec=xconf;startx;kdm the loading process will get stuck and turn into blackscreen while with backlight on.
 
sosoul24
wrote 5 years ago


reply
markds wrote:
Edit your slax.cfg file and change "autoexec=xconf;telinit~4" to

autoexec=cp~/usr/share/slax/xorg.conf~/etc/X11/xorg.conf;telinit~4



i dont know which specific autoexec=??? you ask me to modify so i simply edit all the commands that include "autoexec=???"into"autoexec=cp~/usr/share/slax/xorg.conf~/etc/X11/xorg.conf;telinit~4"
and it doesn't work
BTW i can't reboot or shutdown or poweroff properly everytime i type each commands of above the system wil firstly popup with massege that tell the action is processing and then followed by stuck there so i basically have to end up with brutal poweroff if you know what i mean i don't know wether is this lead to the problem
 
sosoul24
wrote 5 years ago


reply
problem solved!!! hahaha thank you guys

here is what i do i learn lot from all of your help and i follow markds' tip edit the begining menu slax , put in "autoexec=cp~/usr/share/slax/xorg.conf~/etc/X11/xorg.conf;telinit~4" it works!
i dont know if i can properly reboot now cuz i'd rather try it after a while, i've already kill my laptop million times in 2 days

once again thx a lot :)
 

  » search  » forum index  

Post your reply

Your name (Login):

Message:

These HTML tags are allowed: <quote>, <b>, <u>, <i>, <pre>, <code>, <small>, <h1>, <h2>, <h3>, <li>



Slax is generously supported by: P&P Software GmbH and wisol technologie GmbH