Users online right now: 66 - Login  » search  » forum index  

Boot error -- "could not find kernel image: linux

Lugo
wrote 9 years ago


reply
Hi, im newbie in linux... I'm traying to boot linux Slax from USB and works excellent in almost every PC with I have booted from USB but there's one that I can't, this machine came from Taiwan, EWAYCO company (www.ewayco.com) and I'm getting desperated if anyone can help me it would be great,


i repeat the message appear like this when I'm booting:

-----------------------------------
Could not find kernel image: linux
boot:
-----------------------------------

and then I can't do nothing else than reboot again and again and again.


once again thank you for taking time and read my post.


Best regards,
Luis Lugo

PS: sorry for my english I'm from México.
 
em
wrote 9 years ago


reply
Ive the same error last night and i dont find the solution!

Ive copied the content of my usb key to another location, erased the mbr of the key wiht dd in Konsole (dd if=/dev/zero of=/dev/sda (if sda is your key) bs=512 count=63) and reformated it, and reinstall my previous copied SLAX to it. And everything is fine again!

Probably a corrupted mbr or ldlinux.sys files in /boot/syslinux ...

That solve my problem! Never happens to me before since 2 years of Slax!

Have fun!
 
Lugo
wrote 9 years ago


reply
could you make a tutorial for me, really I'm newbie and I don't understand a lot
 
Lugo
wrote 9 years ago


reply
And one more thing when I try to format my USB with ext3 format it's send me an error =S
 
ichaochao
wrote 9 years ago


reply
I have the same error,but i don't know how to solve it,sorry!
 
some-guy
wrote 9 years ago


reply
Lugo wrote:
And one more thing when I try to format my USB with ext3 format it's send me an error =S

?
mkfs.ext3 /dev/sdxx (optionally with the -L parameter to put a label)
then try using these instructions to install extlinux: http://www.slax.org/forum.php?action=view&parentID=4195
 
Lugo
wrote 8 years ago


reply
some-guy i don't understand what do you mean with

mkfs.ext /dev/sdxx

if you can xplain please.


Thanks
 
Lugo
wrote 8 years ago


reply
thanks thanks one hundred thousand million trillion thanks at least i did formated my USB with ext3 and all seems to be right thank you SOME-GUY thank you EM a lot
 
Ace
wrote 8 years ago


reply
I can recomend you to format USB-disk to FAT or EXT3, it has solved my problem.
 
Lugo
wrote 8 years ago


reply
Thank you Ace,


but FAT seems doesn't work and for some reason I can't install EXT3 if you can tell me how to do that will be great
 
Red.Rorester
wrote 8 years ago


reply
I'm not understand
what I'll need to do for solve this problem
Can you tell more
My Slax is on USB
 
fundamental
wrote 8 years ago


reply
Red.Rorester:
I'm not understand
what I'll need to do for solve this problem
Can you tell more
My Slax is on USB

Be specific about where you have the problem.
Do you have difficulties formating to ext3?
Do you have difficulties installing lilo?
Does the problem in this thread apply? (if so please elaborate on how similar of a setup you have)
 
ABC
wrote 8 years ago


reply
hi,
can anybody tell me the error of "no root to the host"wht it comes n how can we remove it?
plz rep soon..thnk u.
 
wervie
wrote 8 years ago


reply
can anyone help me?

when ever i extract slax (using winrar) onto my flash drive (FAT32) it gives me corrupt errors at the very end of the process.

then once i try boot the usb it says the linux kernal is missing (or sumthing like that)

cheers, and thanks for your time
 
wervie
wrote 8 years ago


reply
once i reinstalled it, it didnt say anything about the kernal. it now says (after a whole lotta code)

"FATAL ERROR FOUND
SOMETHING WENT WRONG AND WE CANT CONTINUE. THIS SHOULD NEVER HAPPEN.
PLEASE REBOOT BY PRESSING ALT, CTRL, DELETE"

thanks, hope you can help
 
fundamental
wrote 8 years ago


reply
Did you check the md5sum of the .tar to make sure it was not corrupt?
 
wervie
wrote 8 years ago


reply
hey thanks for helping

i fixed FATAL ERROR FOUND problem. but now it only boots on one of my two computers. one boots absoloutly fine while the other says

Could not find kernel image: Linux
boot:

i know it works on one of my computers so its not corrupt. and the computer it dosent work on has ubuntu installed and working fine so the Linux kernel works fine with it

cheers and thanks in advance. and im loving slax on the computer it works on
 
FJOR1803
wrote 7 years ago


reply
Hi, im newbie in linux... I'm traying to boot linux Slax from USB and works excellent in almost every PC with I have booted from USB but there's one that I can't.

Could not find kernel image: linux
boot:

TANK YOU
 
RaptorX
wrote 7 years ago


reply
what is happening is that for some reason (maybe corrupt mbr) your syslinux is not finding the vesamenu.c32 file... you can try to put it manually:

boot:/boot/vesamenu.c32

if that doesnt work try adding the /dev that it is in (your usbkey in this case)

boot:/dev/sdb1/boot/vesamenu.c32 (thats in my case)

it can happen that that wont work either...

then you should reformat your usb and install slax again.
here is a little howto for making extlinux instead of lilo in EXT2 or EXT3 file system (it also tells you how to reformat and everything just follow up the whole howto)

http://www.slax.org/forum.php?action=view&parentID=11126&highlight=ext2%20extlinux
 
shadow1013
wrote 7 years ago


reply
I just wanna say that using ext3 on a usb disk lowers the life expectancy of the disk because its being written to much more frequently
 
nandini
wrote 5 years ago


reply
em wrote:
Ive the same error last night and i dont find the solution!

Ive copied the content of my usb key to another location, erased the mbr of the key wiht dd in Konsole (dd if=/dev/zero of=/dev/sda (if sda is your key) bs=512 count=63) and reformated it, and reinstall my previous copied SLAX to it. And everything is fine again!

Probably a corrupted mbr or ldlinux.sys files in /boot/syslinux ...

That solve my problem! Never happens to me before since 2 years of Slax!

Have fun!
 
nandini
wrote 5 years ago


reply
could not find kernal image how to solve that
 
Nemai
wrote 1 year ago


reply
I have the same error:
when I start my laptop there was a message like....
"No child node, aborting....
could not find kernel image:/NULL
boot:_"
I dont understand what to do...
can anyone help me?
 
tony syark
wrote 1 year ago


reply
am install backtrack 5 but reboot time i can see could not find kernel image pls help me how to fix
 
beebee0605
wrote 1 year ago


reply
I have the same error,but i don't know how to solve it,sorry!



https://wikorball.buaksib.com
 
Harshal
wrote 1 year ago


reply
Yes i have also the same problem "could not find the kernel image"...plz help me.......
 
forum
wrote 311 days ago


reply
try using this to create a bootable USB drive. http://unetbootin.github.io
 

  » search  » forum index  

Post your reply

Your name (Login):

Message:

These HTML tags are allowed: <quote>, <b>, <u>, <i>, <pre>, <code>, <small>, <h1>, <h2>, <h3>, <li>



Slax is generously supported by: P&P Software GmbH and wisol technologie GmbH