Users online right now: 107 - Login  » search  » forum index  

Installing Slax-6.1.2 to an hard drive

daunted
wrote 4 years ago


reply
Have been looking for a Linux distro suitable for an aging computer with only 256MB memory and was really impressed when i ran Slax-6.1.2 "Live CD". The problem i now have is that i know very little about partitions so is there anyone who could help me install Slax 6.1.2 to an hard drive please. Big thanks
 
shark1
wrote 4 years ago


reply
There is a good tutorial here:-

http://gr8idea.info/os/tutorials/slax/install.html

There is also QTparted - a specialised distro for partitioning. You can create one or more partitions depending on what you might want to install later but only need one for Slax. It is normal to set up a swap partion of about twice your ram.

Brad
 
forum
wrote 4 years ago


reply
Now that looks very promising. Thanks for the reply and linkBrad
 
jayflood
wrote 4 years ago


reply
Excellent. Someone should steal that and use it on the slax FAQ's
 
pegasus
wrote 4 years ago


reply
After doing this and update grub config (I am using GRUB2). When booting, it shows an error "telinit~4 command not found)", also "startx command not found".
I have to remove it and startx manually after boot.

Any advice ? Thanks
 
shark1
wrote 4 years ago


reply
I am not using Grub2 but I have "autoexec=xconf;telinit~4" in the menu.lst file.

Brad
 
jayflood
wrote 4 years ago


reply
pegasus if you followed that tutorial and you are using grub 2 then it certainly won't work. Grub 2 holds its files in different places.

In GRUB 2, the menu configuration file is located at "/boot/grub/grub.cfg". It is automatically generated by "/usr/sbin/update-grub" using templates from "/etc/grub.d/*" and settings from "/etc/default/grub".

It should look something like this
menuentry "Slax" {
set root=(hd0,0)
kernel /boot/vmlinuz ramdisk_size=6666 root=/dev/ram0 rw autoexec=xconf;telinit~4 changes=slaxchanges
initrd /boot/initrd.gz

If you end up at a prompt you should still be able to start using:
# init 4
# startx
 
pegasus
wrote 4 years ago


reply
Hello,
Thanks jayflood and shark1. After some experiments, I think the problem is Grub2 does allow only 1 command in autoexec. Both telinit~4 and startx are "command not found". Why is Grub verifying the boot parameters ?

The workaround is easy, just remove the xconf, leaving startx (or telinit~4) the only command in autoexec.
Since we already have "changes=", I believe xconf has already been saved from the previous session, no need to do it on every boot. Not sure if this hypothesis is correct, but it works for me
 

  » search  » forum index  

Post your reply

Your name (Login):

Message:

These HTML tags are allowed: <quote>, <b>, <u>, <i>, <pre>, <code>, <small>, <h1>, <h2>, <h3>, <li>



Slax is generously supported by: P&P Software GmbH and wisol technologie GmbH