Users online right now: 91 - Login  » search  » forum index  

How to install XFCE only..

Thor
wrote 6 years ago


reply
This is based on my xfce-4.4.2-desktop, found under Slax modulesection "System" (with the XFCE icon, not those commented that can be deleted)


I assume one removes KDE from Slax-6.0.3.iso

Remove the KDE files from the "base" folder of the slax.iso.
3 files have name 003-desktop,004-kdeapps and 005-koffice

Instead add the xfce-4.4.2

To render icons proberly one need to add to more modules
librsvg and libgsf (which have been removed through removing the 003-desktop)

Then choose init 3, where after login you type

"startxfce4" to start the desktop.
 
max
wrote 6 years ago


reply
I have followed your instructions and successfully replaced KDE with Xfce. Problem is, there are no title bars and all windows are static.

Is there perhaps something else I need to install to add the window manager?
 
ben_coh
wrote 6 years ago


reply
You might check your xinitrc file, in /etc/X11/xinit
I think it's still a symlink to xinitrc.kde, or something like that....
You need to make it point toward the xfce initrc
 
max
wrote 6 years ago


reply
Thanks for the quick reply. I have replaced /etc/X11/xinit/xinitrc with a symlink to /etc/xdg/xfce4/xinitrc (that's the only one I could find)

Now I can start Xfce by simply typing startx but still I have no window manager.

Any ideas?
 
Guest
wrote 6 years ago


reply
I think that there may be an compressionerror in the lzm module that was at thor.aidega.es (if you use the "all"). I will check later on it.
 
sevenalive
wrote 6 years ago


reply
Ya i got the same problem, no window manager, could we use compiz-fusion has a window manager, do we have a module for that?
 
ben_coh
wrote 6 years ago


reply
There is a beryl module somewhere on the forum ... (or on the beta modules page, don't remember)
 
Thor
wrote 6 years ago


reply
Should work. Only thing I can think of, coz I have a slightly feeling, was that something went wrong with the upload of the all xfce to the first server. I just have done a retest and no problem here.


Removed the 3 mentioned kde related ones.

added to the modulefolder:

libgsf-1.14.7-i486-1
librsvg-2.22.1-i486-1
xfce-4.4.2-desktop ( I did an all-in-one uplaoded to Slax)


Loaded the new iso in qemu, chose "Slax Text Mode", logged in as root and typed "startxfce4"

All these can now be found in Slax' modulesection


vte-0.16.12-i486-1
is also needed to run Terminal (xfce's cli). I had a slightly problem with the display on Terminal in the iso in qemu. I have no problem on the real-install, so I come back with the solution/module missing
 
yoman64
wrote 6 years ago


reply
Looks like xfce window manager is missing.
I found two workarrounds

Use xfwm4 module from this page http://www.mpchopper.com/slaxmodules1/desktopenvi.html .
If the window manager doesnt start when you launch xfce, just run xfwm4 in a terminal while xfce is running.


The other way is to install (or use if you kept desktop.lzm) fluxbox.
 
markds
wrote 6 years ago


reply
I've got the compiz fusion modules created for gnome slack build, not sure if you can use them on your own, but you can try :

http://backtrack.serveftp.com/backtrack/S6Mirror/Modules/GSB-2.20.3/



sevenalive wrote:
Ya i got the same problem, no window manager, could we use compiz-fusion has a window manager, do we have a module for that?
 
max
wrote 6 years ago


reply
Use xfwm4 module from this page http://www.mpchopper.com/slaxmodules1/desktopenvi.html .
If the window manager doesnt start when you launch xfce, just run xfwm4 in a terminal while xfce is running.


Thanks, that works for me but it would be nice if it could be auto-started at xfce launch.

I also cannot understand why this would be missing from the *all* module.
Perhaps the lzm compression is corrupt as was previously suggested.
 
yoman64
wrote 6 years ago


reply
max wrote:
Use xfwm4 module from this page http://www.mpchopper.com/slaxmodules1/desktopenvi.html .
If the window manager doesnt start when you launch xfce, just run xfwm4 in a terminal while xfce is running.


Thanks, that works for me but it would be nice if it could be auto-started at xfce launch.

I also cannot understand why this would be missing from the *all* module.
Perhaps the lzm compression is corrupt as was previously suggested.


Thats weird, mine is auto-started. But if you have issues you probably can start via the autostart of xfce:

Go in the menu>settings>autostarted applications and add xfwm4.

On my side I still have issues with that "all in one" module, icons aren't all rendered in the settings panel, I am not able to put icons on the desktop( And I know that xfce 4.4 is able to) and pictures "thumbnails" in Thunar doesn't work (You know, when you see a thumbail of the picture instead of the Thunar ugly icon fir tge files).

I hope somebody will rebuild a true all-in-one working module :(
 
Thor
wrote 6 years ago


reply
yoman64 wrote:
max wrote:

On my side I still have issues with that "all in one" module, icons aren't all rendered in the settings panel, I am not able to put icons on the desktop( And I know that xfce 4.4 is able to) and pictures "thumbnails" in Thunar doesn't work (You know, when you see a thumbail of the picture instead of the Thunar ugly icon fir tge files).

I hope somebody will rebuild a true all-in-one working module :(



Use xfwm4 module from this page http://www.mpchopper.com/slaxmodules1/desktopenvi.html .
If the window manager doesnt start when you launch xfce, just run xfwm4 in a terminal while xfce is running.


Thanks, that works for me but it would be nice if it could be auto-started at xfce launch.

I also cannot understand why this would be missing from the *all* module.
Perhaps the lzm compression is corrupt as was previously suggested

Thats weird, mine is auto-started. But if you have issues you probably can start via the autostart of xfce:

Go in the menu>settings>autostarted applications and add xfwm4.



you shoud read all. Thunar is a Slax issue. you need the 2 mentioned libs. A few settings-manager icons miss, but does so also in the slackrep's xfce. You can probably just link them to /usr/share/pixmap. It may also be due to yet another missing libpackage in slax. Keep in mind that Slax is pretty stripped. You can also use another icontheme, like gnome, but the xfce icons will be recompiled. just dont know what is exactly the thing, coz when i compiled the gnome+-icon-theme, all xfceicons were properly replaced, also the settings-manager. I doubt a recompile will help, since I ran into just the same thing using the official slackxfce. You may though, try that other rodent icon theme, found under Artwork. It may be more complex and due to compiling of the icon tools in Slackware, than merely a recompile. Dont know yet.

Thunar problem is at least np, when you get the described libraries. Where did you get the module btw. Would be nice to know. From the modulesection??
 
yoman64
wrote 6 years ago


reply
Hi,
I have read ALL your post , I'd never say "it doesnt work" without having following all the steps :) So I do have the two missing libs, without them no icons shows up, with these 2 or 3 icons appear but there's still missing a lot. I'll try what you says, getting icons elsewhere and mapping them in pixmaps.

I don't have access to slax module section, I followed the page you were talking about ahead "thor.aidega.es" and I arrived to this page http://www.mpchopper.com/slaxmodules1/desktopenvi.html , there I took the xfce-all module!

thanks for the help
 
Thor
wrote 6 years ago


reply
yoman64 wrote:
Hi,
I have read ALL your post , I'd never say "it doesnt work" without having following all the steps :) So I do have the two missing libs, without them no icons shows up, with these 2 or 3 icons appear but there's still missing a lot. I'll try what you says, getting icons elsewhere and mapping them in pixmaps.

I don't have access to slax module section, I followed the page you were talking about ahead "thor.aidega.es" and I arrived to this page http://www.mpchopper.com/slaxmodules1/desktopenvi.html , there I took the xfce-all module!

thanks for the help


pls post how it goes. I'll dig into it, when Im done with some realwork. I suggest that you instead try the xfce found in the modulesection. It is a recompile from scratch without any windowmanager atall installed at compiletime. It is found under System. The only xfce package with the xfce icon displayed. I recommend that to all who have the other. I noticed some issue too, when removing the whole KDE, aka the recompile with no windowmanager.
 
Thor
wrote 6 years ago


reply
yoman64 wrote:
Hi,I don't have access to slax module section, I followed the page you were talking about ahead "thor.aidega.es" and I arrived to this page http://www.mpchopper.com/slaxmodules1/desktopenvi.html , there I took the xfce-all module!

thanks for the help


This is def due to a compile with KDE installed. Pls exchange it with the "all" in the System section (with icon), and tell how it went. I'll pop by later. I have verified the issue. I will remove that link, sry
 
yoman64
wrote 6 years ago


reply
Hi, I don't have access to slax module section, can you host the module elsewhere ? Or maybe Tomas plan to open publicaly the module section really soon ?
 
jmdlcar
wrote 6 years ago


reply
Here is a list of modules that works for me.

I took out 003, 004 and 005.

aspell-0.60.5-i486-2.tgz*
aspell-en-6.0_0-noarch-4.tgz*
cdparanoia-IIIalpha9.8-i486-2.tgz*
cdrdao-1.2.1-i486-1.tgz*
cdrtools-2.01.01a23-i486-1.tgz*
dvd+rw-tools-7.0-i486-2.tgz*
flac-1.1.2-i486-3.tgz*
gnome-icon-theme-2.14.2-noarch-2.tgz*
libao-0.8.6-i486-2.tgz*
libgsf-1.14.3-i486-1.tgz*
libid3tag-0.15.1b-i486-2.tgz*
librsvg-2.16.1-i486-1.tgz*
lm_sensors-2.10.3-i486-1.tgz*
mozilla-firefox-2.0.0.4-i686-1.tgz*
pcre-7.0-i486-1.tgz*
python-2.5.1-i486-1.tgz*
rdesktop-1.5.0-i486-2.tgz*
taglib-1.4-i486-3.tgz*
vorbis-tools-1.1.1-i486-4.tgz*
vte-0.16.5-i486-1.tgz*
wpa_supplicant-0.5.7-i486-1.tgz*
xaw3d-1.5-i486-4.tgz*
xfce-4.4.1-i486-5.tgz*
 
yoman64
wrote 6 years ago


reply
Erf I talked too fast, icons in setting panel still doesnt shows up. In fact the only thing working back it is icons on desktop.

But when I install it over kde icons does appear in setting panel. I guess theres one more librarie needed but which one :(
 
yoman64
wrote 6 years ago


reply
Alright icons are almost all working , just has Thor said, symlink did it :) Thanks everybody
 

  » search  » forum index  

Post your reply

Your name (Login):

Message:

These HTML tags are allowed: <quote>, <b>, <u>, <i>, <pre>, <code>, <small>, <h1>, <h2>, <h3>, <li>



Slax is generously supported by: P&P Software GmbH and wisol technologie GmbH