Users online right now: 132 - Login  » search  » forum index  

WINE installation under SLAX

Stuckemuck
wrote 1 year ago


reply
Hi all!

I've just downloaded SLAX 7.0.2 and everything is working fine. Even my notebooks internal speakers are working very well with SLAX. Although WLAN isn't accessible, LAN support is all I need and that's fine.

What I'm missing is a way to install WINE under SLAX. I've searched the net but couldn't come up with a special built of WINE for SLAX. The only thing I found was a built for Slackware (WINE v1.5.2).
But as a novice Linux/SLAX user I have no knowledge how to install this (or any other WINE built version).

Is there a "WINE under SLAX for dummies" faq or wiki or something else?
Or is anybody able to show me what to do to get WINE up and running?

Happy new year
Alf
 
jcsoh
wrote 1 year ago


reply
Wine by em's:-
Search this thread:-
http://old.slax.org/forum.php?action=view&parentID=83194
 
Stuckemuck
wrote 1 year ago


reply
OK, thx for the links.
I've downloaded the Wine-Package for X64 and unsquashed it which gives me two folders, "usr" and "var".
What must I do to get Wine installed? Is it enough to just copy those folders to my root/SLAX directory?
As mentioned before I'm a novice Linux user with some newbie question.
 
jcsoh
wrote 1 year ago


reply
It's a slax 7 bundle which is slax 7's native format .So it ready for use.
Slax is modular , so if you look in /slax , you see the base bundles , eg 001_core.sb , 002_xorg.sb etc
This are also bundles but they are the base modules . Do not remove /delete without knowing what you are doing.
For additional software the same principle applies .You can place the software file.sb together with the base file.sb as well , but to avoid confusion put them in ./modules.

This is applicable to all slax bundle which is filename.sb (have sb extension).
Put slax bundle in /modules where slax will auto activate them at the next reboot.

You can also activate the bundles on the fly (Note some bundle need to be activate at reboot to work).
Use Dolpin file manager and navigate to /modules
Right click with the mouse on the Desktop
Choose from the pop up menu
Action
Open Terminal Here
Type ls (ls = list to list out the directories /files in /modules

Type

slax activate filename1.sb for eg to activate a bundle named filename1.sb

To deactivate

slax deactivate filename1.sb for eg to deactivate a bundle named filename1.sb

Type slax to see various option.

Read documentation -Read the Module Tab at least.
Activating Slax Module
http://www.slax.org/en/documentation.php

Modules or Bundles is what make Slax special.
 
jcsoh
wrote 1 year ago


reply
You did not mention how you installed slax. The above is only true is your slax is in a frugal /live cd mode.
Look in /slax
If your slax installation still have 001_core.sb ,002_xorg.sb , 003_kde.sb etc , then is ok.
But if the file with sb extension is not there and if you are having folders like /usr , /share , home etc , then you better tell us what you did to install.

Slax extracted the bundles in ram and recreated it file structure.
Go to /mnt/live/memory

You see

/changes
/union
/bundles

Take a look to have an idea , for eg you see the bundle /software in /bundles.
Since the bundle are not actually physically extracted , if you decide you no longer want the bundle , you can just delete it away.
 
Stuckemuck
wrote 1 year ago


reply
Thanks. I have installed SLAX on USB and just looked at my bundles folder at mnt/live/memory.
It's just as you've said. I have the files "01-core.sb", "02-xorg.sb" and so on.
So I copied the Wine bundle to the modules folder and rebooted.
It seems the module has been activated, but Wine is nowhere to be seen.
Maybe I'm blind but I thought there would be some kind of "Wine" addition anywhere in the applications menue.
I did a simple search on Wine and KDE showed me something like "start wine". But clicking on it changed really nothing. No Wine, no WineCFG or anything else.

Reading the Winedocs on Winehq I stumbled upon something like "add application" which - I thought - is the correct way to add a program to be started through Wine.
Man, this seems to be a really complicated thing. I surely made a mistake, but I can't guess exactly what I did wrong.
Trying to activate the Wine-module manually through "slax activate wine-1.5.20-x86_64-2-MDS.sb" only gave me the message that this module has already been activated. But it seems I can't access Wine anywhere. Strange.
Any advice what I did wrong?
 
jcsoh
wrote 1 year ago


reply
"It seems the module has been activated, but Wine is nowhere to be seen.
Maybe I'm blind but I thought there would be some kind of "Wine" addition anywhere in the applications menue."

It's a common problem . I almost willing to "swear" it's delibrate to discourage user from using wine to run window software :).

Open a terminal and type
wine
If you get :-
root@slax:~# wine
Usage: wine PROGRAM [ARGUMENTS...] Run the specified program
wine --help Display this help and exit
wine --version Output version information and exit
root@slax:~#

Then wine is up and running . Sometime a menu entry only appear after the first run.
I am using Em's wine bundle (32 bits).
There is a wine item in the menu but I am not sure when it appear.

Ok to use wine , say your window programme executable is named runme.exe.
Right click runme.exe and choose from the pop up menu , Open with wine .
If there is no open with wine , choose open with other , then type wine in the box.

For very simple programme and stand alone portable programme , they might run directly with wine.

For most /more complex programme , you actually need to use wine to install it , rather than run directly.
Use wine to run the install.exe (or whatever installer.exe).
Basically wine will fools the programme into thinking that they are installing to a fake C drive.

In slax 6 , this can be seen in /mnt/live/memory/changes/root/.wine (Note the "." dot infront of wine means it's a hidden folder so you file manager setting must allow showing of hidden folders /files.
You will see a drive c

I haven't installed anything in slax 7 with wine yet , so I am not sure if it is the same in slax 7.
Summary

Basically , right click a window programme exe file , choose open with wine to run window executable.
 
Stuckemuck
wrote 1 year ago


reply
That's what I'm wondering about:
The module is up and running, but type "wine" in a terminal only gives me the error "no such file or directory".

I think I won't get into much trouble installing some Windows software if Wine is installed correctly on my system. But although the module has been activated I have no command to access Wine at all.

Maybe I'm missing some other modules to get Wine running.
Do I have to install Python or anything else?
 
jcsoh
wrote 1 year ago


reply
No the wine bundle should be complete . So far as I can recall wine module or source package are stand alone . The Gecko /mono are extra .Perhap a bad download?

You can test.
Go to /modules
Open a console
Type

slax activate wine_full_name.sb

See what it say .

Or get your own wine:
http://slackfind.net/en/packages/search/?name=wine&distversion=

Convert from console

txz2sb wine_full name.txz

Wait till the window close by itself . Do not close even at 100% otherwise the bundle will have error.

Then from a console

slax activate wine_full_name.sb
 
Stuckemuck
wrote 1 year ago


reply
Thx, I'll download two fresh copies, one for amd64, one for i486 and will try both.
I'll get back on this in some minutes.
 
Stuckemuck
wrote 1 year ago


reply
What a shame - it's all the same.
Nothing has changed. Converting and activating Wine as a module works with no errors.
But typing "wine" in the terminal always gives the response "No such file or directory".
Just like before, no matter which Wine version I choose.
 
Stuckemuck
wrote 1 year ago


reply
Can it be that I'M missing a library like libc6-i386 or something else?
I'm running an amd64 version of SLAX. Is that the problem?
 
jcsoh
wrote 1 year ago


reply
I can't say as I have never run the 64bits version of slax (Note slax 7 is the first with a 64 bits version).
Just in case , linux is case sensitive , so you must type exactly

wine will work
Wine or WINE won't work

Here another source of 64 bits bundles . It have wine (see end of the list).
http://backtrack.serveftp.com/doku.php/backtrack/slax_7_modules
 
Stuckemuck
wrote 1 year ago


reply
That was the version I tried first (it came from your forum link).
I think I'll give SLAX 32bit version a chance and try Wine on it.
 
jcsoh
wrote 1 year ago


reply
Trying to activate the Wine-module manually through "slax activate wine-1.5.20-x86_64-2-MDS.sb" only gave me the message that this module has already been activated.

I reread your post . The above would suggest the wine module is already activated (the message comes about when you try to activate a module that have been activated). In which case opening a terminal anywhere and typing wine should brings up wine option.
,
The only idea I have left , is if you are testing wine with a whole bunch of other bundles , then to try test wine alone (meaning no othe bundles) , in case one of the other module that you are using is some how interfering.

Otherwise post at EM's module thread . Maybe he will answer.
 
bb as guest
wrote 1 year ago


reply
It is not uncommon to need to first run 'winecfg' from a terminal to get started; that is what creates the /root/.wine/ directory structure, and may also create some K menu entries. Don't ask me to explain this, just sloppy module-making IMO.

In the general case, while still in winecfg tell it to autodetect your partitions. Then after opening an .exe file with wine, before running it you must return to winecfg and 'add' the application to wine's configuration. This is not necessary for the simplest programs, but will be necessary for many others.

There is now a native 64-bit version of wine, though I have not been successful at getting it to work correctly on Slax7-64. Haven't seen it offered on other 64-bit distros, they mostly only offer 32-bit wine.

Using 32-bit wine on 64-bit linux requires the addition of compat-32 libraries -- typically a 50mb addition to the main wine.sb module. You can generally just 'cancel' when a wine install complains about the need for gecko.

Suggest that you begin getting acquainted with wine on 32-bit distros [like slax6 for example, many versions of wine work well on that platform].

I have in general been disappointed with all 64-bit linux -- IMO they offer nothing worthwhile over the traditional 32-bit distros.
 
Stuckemuck
wrote 1 year ago


reply
OK, got it up and running on SLAX 32bit.
As far as I found out it's an issues with SLAX 64bit. Has womething to do with 32bit programs and multilib or something like that.

Anyway another problem:
when I use to install a program through Wine it always says "could not exec wineserver".
Any suggestions?
 
Stuckemuck
wrote 1 year ago


reply
Hm, in another forum I came across this posting:
"I added /opt/wine/bin to /etc/ld.so.conf and reran /sbin/ldconfig but
that didn't solve the problem. Then, I added a symlink in /usr/bin:
wineserver to /opt/wine/bin/wineserver, and that solved the problem!!"

Can anybody tell me how to add a symlink like that?
 
Stuckemuck
wrote 1 year ago


reply
hm, I think this doesn't solve the problem.
I tried to install the symlink with "ln -s /usr/lib/wine/wineserver /usr/bin"
but this symlink already existed (error "file exists").
Why must it be so damn complicated to get this running?

Anyone who knows what is missing to get my Wine install working?
 
Stuckemuck
wrote 1 year ago


reply
OK - solved.
Believe me or not. It was an issue of the latest version.
I went back to an older 32bit version of Wine (v1.4) and everything seems to be fine.

So let's have a try with some Win programs.

A big thx to everyone holding my hand with these issues!
 
forum
wrote 1 year ago


reply
jcsoh wrote:
Wine by em's:-
Search this thread:-
http://old.slax.org/forum.php?action=view&parentID=83194
 
Vick
wrote 1 year ago


reply
Perhaps, you need to type wine64 in the box for "Open with". The 64-bit wine comes with wine64 exec. Also as someone said, you might need to first setup the config (ie create the /root/.wine).
 
hola
wrote 278 days ago


reply
comence a usar wifislax,, mi pregunta es ¿ porque se vuelve IMMPOSIBLE instalar wine en esta distribucion?
no sirve el comando sudo, no sirve apt-get,, en ningun foro esta la solucion aparente ni en google,,
por favor se los ruego,, pasenme un manual ,, acepto que debo aprender , no me lo pongan tan facil ,, pero tampoco quiero que parezca imposible,, no encuentro manual que sirva para wifislax ,, ya probe los de slax y se ven diferentes no se puede instalar nada aca con eso,, de antemano gracias,, en serio muchas gracias,,
 
philoj
wrote 167 days ago


reply
Hi,
I had the same problem. Anyway, wine64 instead of wine solved the problem. Had to replace wine with wine64 in /usr/bin/winecfg to start winecfg
 

  » search  » forum index  

Post your reply

Your name (Login):

Message:

These HTML tags are allowed: <quote>, <b>, <u>, <i>, <pre>, <code>, <small>, <h1>, <h2>, <h3>, <li>



Slax is generously supported by: P&P Software GmbH and wisol technologie GmbH