Users online right now: 71 - Login  » search  » forum index  

Installing Slax 6.1.2 to hdd

Chazfem
wrote 197 days ago


reply
Hi, I love Slax I think it's a really great distro and want to use it on an old P3 256mb ram laptop. I really need it to be installed onto the hdd as i need the usb port for a wireless adapter and my daughter might want to play some CDs on it. It will be the only OS installed on it.

I partitioned the hdd to have a 25Gb fat32 storage, a swap, extended and 2.5Gb ext3 partition as the boot for Slax. I loaded the live CD, copied the boot and slax folder to the slax partition (hda1). I followed the instructions (see link) and updated the liloinst.sh folder using kwrite.

http://gr8idea.info/os/tutorials/slax/install.html

Now when it comes to running liloinst.sh to make it work I run into difficulties. I open up the Shell - Konsole and I typed "bash/mnt/hda1/boot/liloinst.sh".
All I get is -bash: ./liloinst.sh: No such file or directory.
I tried "mnt/hda1/boot/liloinst.sh"
I tried "bash/mnt/media/hda1/boot/liloinst.sh"
I tried "bash/mnt/system/media/hda1/boot/liloinst.sh"
I tried "chmod +x liloinst.sh"
I tried "./liloinst.sh"
I tried "su" (not sure what that does exactly but I'd run out of everything else)

Al of these I have tried many many times. I tried re-copying the folders. I tried doing it without modifying the contents of liloinst.sh folder. But always I get the line "No such file or directory"

Could somebody please point me in the right direction here please. It sounds like I'm telling it to look in the wrong place for the file but I can't see that I am. When I'm looking at the file the location in the address bar is "system:/media/hda1/boot" Anyway shouldn't "./" work for any location?

For any answers please bear in mind that I am new to linux and will probably need things spelled out pretty well! Thanks!

PS Sorry for any bad grammar/sloppiness, it's 3AM and I am at my wits end with this!
 
jcsoh
wrote 197 days ago


reply
When you open the console you should get (if you are running as root (slax's default))
root@slax:~#

Don't run the command with long path , but rather go inside the location is actually is , the only run the command.

For eg
"bash/mnt/hda1/boot/liloinst.sh"

The bash part is wrong

cd /mnt/hda1/boot to go inside boot (assuming the liloinst.sh is)
then

./ liloinst.sh

If you find it hard to navigate , get a file manager like krusader .
You will a gui file manager to navigate to where you need to be , then from the menu , choose open console here . This will open the console in the selected folder (right path).
 
Chazfem
wrote 197 days ago


reply
Thank you for your reply jcsoh. I tried cd/mnt/hda1/boot and it didn't work initially but then I realized there was supposed to be a space after cd and it worked! Thank you so much!!! I was about 5 hours trying to figure that one out. Virtual fruit basket is on its way :D
 

  » search  » forum index  

Post your reply

Your name (Login):

Message:

These HTML tags are allowed: <quote>, <b>, <u>, <i>, <pre>, <code>, <small>, <h1>, <h2>, <h3>, <li>



Slax is generously supported by: P&P Software GmbH and wisol technologie GmbH